Back to overview
Downtime

Singtel service interruption

Jan 23 at 06:00pm GMT+8
Affected services
Singtel

Resolved
Jan 23 at 06:05pm GMT+8

18:00hrs: Please be informed of a Singtel service interruption, where users may experience delays in receiving messages. We will update once normal service resumes.

Created
Jan 23 at 06:00pm GMT+8

18:00hrs: Please be informed of a Singtel service interruption, where users may experience delays in receiving messages. We will update once normal service resumes.