Back to overview
Singtel and Starhub service degradation
Apr 01 at 12:20pm GMT+8
Affected services
Singtel
Starhub
Resolved
Apr 01 at 12:20pm GMT+8
Please be informed of a Singtel and Starhub service interruption, where users may experience delays in receiving or fail to receive messages. We will update once normal service resumes.
[Update]
We have detected an issue due to increased failures affecting Singtel and Starhub recipients. Upon further investigation, we have confirmed that these are genuine failures related to specific recipients using Starhub and Singtel services.
We apologise for any alarm or inconvenience this may have caused.
Affected services
Singtel
Starhub