Back to overview
Degraded

Large Campaign on 13 May 2025

May 13 at 08:00am GMT+8
Affected services
Single send
Batch send

Resolved
May 13 at 11:15pm GMT+8

The large campaign has concluded. Thank you for your patience.

Created
May 13 at 08:00am GMT+8

Single and batch send messages may be delayed due to a large campaign on 13 May 2025 (Tuesday). Please avoid sending non-critical messages if possible.