Back to overview
Degraded
Singtel service interruption
Feb 10 at 11:33pm GMT+8
Affected services
Singtel
Resolved
Feb 11 at 12:07am GMT+8
The incident has been resolved and services have resumed as per normal. Thank you for your patience!
Affected services
Singtel
Created
Feb 10 at 11:33pm GMT+8
10 Feb 2025 23:33:00 to 11 Feb 2025 00:07:00
Please be informed of a Singtel service interruption, where users may experience delays in receiving or fail to receive messages. We will update once normal service resumes.
Affected services
Singtel