Back to overview
Downtime
Singtel service interruption
Feb 17 at 02:31am GMT+8
Affected services
Singtel
Resolved
Feb 17 at 02:37am GMT+8
The incident has been resolved as of 2:13am and services have resumed as per normal.
Affected services
Singtel
Created
Feb 17 at 02:31am GMT+8
Please be informed of a Singtel service interruption that occured between 1:20am to 2:13am, where users may experience delays in receiving or fail to receive messages. We will update once normal service resumes
Affected services
Singtel