Back to overview
Degraded

Large campaign from 1-4 April 2025

Mar 28 at 06:02pm GMT+8
Affected services
Batch send

Resolved
Apr 04 at 10:22am GMT+8

The large campaign has concluded. Thank you for your patience.

Created
Mar 28 at 06:02pm GMT+8

Batch send messages may be delayed due to a large campaign from 1-4 April 2025 (Tuesday to Friday). Messages may not be sent instantly but will still be cleared within 24 hours as per Postman batch send SLOs: 90% of messages sent within 24 hours.